SQL Server Denali should support SQL 2000 compatibility level (80)

This can be good news for many folks. SQL Server Denali still supports compatibility level 80 (SQL 2000) for databases hosted on this. This means you can go ahead and migrate to future release of SQL Server (Denali – possibly SQL Server 2011) even if your databases are still running on compatibility level 80 (SQL 2000).


However please be advised that it is not a good idea to keep running your database on an older compatibility mode. Hence if any of your database are still using compatibility level 80 on a SQL 2005, SQL 2008 or SQL 2008 R2 instance, it is time to upgrade the compatibility with high priority.


Comments